Расшифровка в СКД(программное заполнение) | Форум поддержки читателей книги "Практическое пособие разработчика. Примеры и типовые приемы"
Софт. Программы для компьютера. Для пк

Ссылка на сообщение Ссылка включая название темы Ссылка URL x. Есть простой отчет на СКД, строящийся по оборотной таблице регистра накопления "Время работы на объектах".

Расшифровка в 1С в отчете на СКД (системе компоновки данных)

Можно ли доработать отчет так, чтобы нажав по определенной строке сформированного отчета открывалась бы расшифровка данной строки по документам-регистраторам? Для этого в наборе данных должен присутствовать Регистратор документ, сделавший движения. Последний выдох ГПЖ в периодичность вроде достаточно вставить "авто". Я добавил "Регистратор" в набор данных. В отчете пункт меню "Расшифровать" присутствует, но почему-то недоступен.

Всё разобрался, расшифровка работает только по тем полям, по которым есть группировка: Кто-нибудь знает, можно ли расшифровку сделать для любого поля, а не только для группировочного?

Расшифровка СКД 1С 8.3

Сделал другой вариант отчета с собственной процедурой программной компоновки. Никак не могу понять, почему расшифровка не работает: ПолучитьФорму "ФормаОтчета" ; Форма. ЗагрузитьНастройки Настройки ; Отчет. ДанныеРасшифровки ; КонецЕсли; КонецЕсли; КонецПроцедуры Процедура СформироватьОтчет ТабличныйДокумент, ДанныеРасшифровки Экспорт ТабличныйДокумент.

Программная расшифровка отчета на скд

УстановитьДокумент ТабличныйДокумент ; ПроцессорВывода. Вывести ПроцессорКомпоновкиДанных ; КонецПроцедуры.

Программная расшифровка отчета на скд

Опубликовано в рубрике Xerox
Twitter Delicious Facebook Digg Stumbleupon Favorites More
  • Прикрепленное видео

Все права защищены. © 2001 toozza.ru